Tag 3: Der NanoESP im AccesPoint-Modus

Hinter dem dritten Türchen befindet sich der für viele Versuche wichtige Schaltdraht. Als Vorbereitung für spätere Versuche können Sie die Versorgungsleitungen GND und VCC auf die äußeren Bahnen legen. Dadurch haben Sie später einen besseren Zugriff auf diese wichtigen Leitungen.

Die Drahtbrücken an GND und VCC

Die Drahtbrücken an GND und VCC

In dem Projekt des heutigen Tages kommen Sie nun dazu, auch selbst etwas in dem Programm zu verändern. Als Grundlage dient uns dabei das Beispielprogramm:

Datei > Beispiele > NanoESP > Basics > AccesPoint

Wenn Sie dieses Programm hochlanden sehen Sie zunächst keine Veränderung. Noch immer ist ein offenes WLAN mit dem Namen NanoESP in Reichweite. Wenn Sie nun aber im Programm die Zeile 16 mit dem configWifi-Befehl verändern, ändern sich auch die AccesPoint Einstellungen.  Sie können das NanoESP in Anführungszeichen durch einen anderen WLAN-Namen ersetzen oder Sie können sogar ein Passwort für das Netzwerk definieren, in dem Sie den letzten Parameter der Funktion anpassen. Das Passwort muss aber mindestens 8 Zeichen haben. Ein mögliches Beispiel lautet:

nanoesp.configWifi(ACCESSPOINT, „MyNanoESP“, „MyPassword“);

Dann müssen Sie das Programm erneut hochladen. Wenn die Konfiguration erfolgreich war, leuchtet die LED D3 zur Bestätigung. Gab es einen Fehler, leuchtet die LED nicht und Sie müssen die Einstellungen überprüfen. So einfach war es noch nie sein eigenes WLAN zu erstellen.

Day3_1

47 Kommentare

  1. Stephan

    Hi, ich habe den Namen verändert und ohne Fehler hochgeladen, also statt
    if (nanoesp.configWifi(ACCESSPOINT, „NanoESP“, „“)) digitalWrite(13, HIGH);
    einfach
    nanoesp.configWifi(ACCESSPOINT, „Stephan“, „Weber“)) digitalWrite(13, HIGH);

    aber statt des neuen Namens „Stephan“ sehe ich immer noch das Netzwerk „NanoESP“.

    1. Stephan

      hmm, o.k. the password was too short..

    2. mio

      a) Die Hochkomma müssen oben sein; nicht „ sondern “
      b) PW mindestens 8 Zeichen

  2. McAllister

    Moin,
    die heutige WLAN-Aufgabe ging relativ gut.
    Aber mit der „Hardware“ habe ich meine Probleme.
    Aufgabe: „…können Sie die Versorgungsleitungen GND und VCC auf die äußeren Bahnen legen.“

    Was zur Hölle? Sorry, bin Noob. Aber was ist GND und was ist VCC? Hätte ich das wissen sollen?

    Und wie muss hier verkabelt werden? Nach Bild kann ich nur interpretieren:
    – 1 „U“ gebildet und in die Eingänge X20 und B20
    – 1 weiteres „U“ gebildtet und in die Eingänge Y20 und J20
    – und Isolierung dazu ab

    Wäre das richtig?

    1. Zmash

      Wenn dein Nano genau so wie auf dem bild gesteckt ist und du die kabel wie du beschreiben hast gesteckt hast, hast du alle richtig gemacht. Finde aber auch, dass dies leider nicht gut beschrieben wurde, da auf dem Board schließlich bei der Markierung 5V steht :-)

    2. Dominik

      Moin McAllister,

      nein ich glaube nicht, dass du das voher hättest wissen sollen. Ich denke was Fabian Kainka hier macht ist, dich nicht in Watte packen. er hätte auch andere Bezeichnungen benutzen können die im ersten moment leichter zu verstehen sind. Irgendwann trifft man als Elektronikbastler aber immer mal auf verwirrende Bezeichnungen und muss lernen was sie bedeutet. Oft muss man sich selbst zu helfen wissen …

      Hier hilft mal wieder die gute alte Wikipedia:
      https://de.wikipedia.org/wiki/Spannungsbezeichnung

      Bei google „Was bedeutet Vcc“ eingeben bringt einen da relativ zügig hin.

      Natürlich hätte Fabian den Text aus der Wiki in die Anleitung kopieren können, wenn er der Meinung ist, dass du an Tag 3 lernen sollst was VCC und GND bedeuten, aber ich glaube er wollte dich sanft in die wunderbare Welt der Elektronik-Tüftler einführen … und da heisst es:

      Versteh ich nicht? Egal, ich kanns rausfinden! Packen wir’s an :-D

      Ich wünsche dir noch viel Spass mit deinem Kalender …

    3. mio

      Die beiden äußeren Bahnen des Steckbrett werden später mit weiteren Komponenten (z.b Temperatur-Sensor, LED ..) verbunden. Die brauchen Spannung (=VCC) und Masse (GND = Ground).
      Da man auf dem Nano aber nur jeweils ein PIN für GND und einen für VCC hat, verbindet man die PINs mit den äußeren Bahnen des Steckbrett. So kann man mehrere Komponenten gleichzeitig mit Spannugn und Masse versorgen

  3. kub0185

    nanoesp.configWifi(ACCESSPOINT, „MyNanoESP“, „MyPassword“);

    ist bestimmt fasch und soll bestimmt

    nanoesp.configWifi(ACCESSPOINT, „MyNanoESP“, „MyPassword“);

    richtig?

    1. sumero

      ?? wo ist das Problem bzw. der Unterschied ??

  4. Nachtlicht

    Bei mir hats soweit funktioniert.
    Ich habe dann das geänderte file unter einem anderen Namen abgespeichert. Zunächst „irgendwo“ – dann gab es jede Menge Kompilierungsfehler weil die #include files nicht gefunden wurden.
    Dann hab ich es neben den „example“ ordner abgespeichert. Komisch, da wird dann nicht nur ein file gespeichert, sondern ein ganzer Ordner mit dem Namen (z.B: „MyAccessPiont“) eingerichtet.
    Wozu braucht es diesen Ordner??

    Dann wollte ich – nach einer weiteren änderung nochmal abspeichern. Da gab es eine Fehlermeldung „Some files are read-only so you’ll need to re-save the sketch to another location“
    Will ich aber nicht !!! Was tun??

    1. Nachtlicht

      Lösung selbst gegoogelt und gefunden:

      Die eigenen sketch files und ordner müssen ausserhalb des „libraries“ ordner liegen.
      Die #include files werden trotzdem gefunden.

      Nun kann ich beruhigt einschlafen….

  5. Daniel

    Bei mir wird der ESP Chip bei Benutzung sehr heiß.
    Ist das normal?

    1. Nachtlicht

      Ja – Scheint so …
      habe mal ein Wärmefoto mit flirone gemacht.
      Demnach liegt die Temperatur bei über 70 Grad!

      1. sumero

        Nach welcher Zeit wird diese Temperatur bei erreicht?
        Meiner bleibt relative kalt, zumindest strahlt er keine spürbare Wärme ab, ich lass das Board allerdings auch (noch) nicht ewig laufen.

  6. wolverine2070

    Ich kann mein Arduinoprogramm nicht mehr öffnen! Dort steht dann, dass ich meine IDE in einen anderen Ordner bewegen soll! Was ist damit gemeint?

    1. mio

      Die IDE ist die Entwicklungsumgebunng; also Dein Editor, wo Du das Coding (sogenannte Sketche) erstellst, speicherst, änderst.

      Es ist möglich, dass Du die IDE in einem Ordner installiert hast, der schreibgeschützt ist.

      Gehe mal in der IDE auf Sketch > Zeige Sketch Ordner.
      Versuche dann mal in diesem Ordner irgendeine Datei anzulegen (z.B. Word, EXCEL oder sonst was)

      Wenn das nicht funktioniert ist der ORdner wahrscheinlich schreibgeschütztz

  7. Lars

    Kann es sein, dass das Passwort exakt 8 Zeichen lang sein muß?

    1. Paul

      Nein, meins ist 9 Zeichen lang
      es muss halt nur mindestens 8 Zeichen lang sein

  8. Andi

    Hat noch jemand das Problem, das er sich nicht mit dem NanoESP per Wlan verbinden kann, sobald ein Passwort vergeben wurde ?
    Das das Passwort mindestens 8 Zeichen lang sein muss, ist mir klar, aber es funktioniert trotzdem nicht.

    1. Markow

      Ja, habe mit meinem MacBook 2016 (Sierra) das gleiche Problem. Bisher keine Lösung.

      1. Jan

        bei meinem iMac mit Sierra (10.12.1) geht es ohne Probleme. Ich hatte testhalber das Passwort toptopsecrect123 gesetzt.

    2. µC-Junkie

      Auf meinem Win7 ist es auch so, ohne Passwort geht es sofort, mit PW (8 Zeichen und mehr) bisher nur ein einziges mal. Dagegen mit verschiedenen Androids und Vista funzt es auf der Stelle. Scheint der Laptop-WLan-Adapter das Problem, obwohl mit anderen AccessPoints sonst keine Probleme.

    3. Tech_Nick

      Das könnte an deinem funkmodul im computer liegen… also einfach mal eine problembehandlung zum funkmodul starten und dann sollte das funktonieren ;)

  9. Yeezy-24

    Hey Leute,

    in der Beschreibung steht: „Noch immer ist ein offenes WLAN mit dem Namen NanoESP in Reichweite.“

    Bei mir wird aber gar kein NanoESP WLAN angezeigt. Ich sehe nur mein normales WLAN.

    Was mache ich falsch? :-/

    1. Yeezy-24

      Hat sich schon erledigt :)

      1. ottoplev

        das Problem habe ich auch. Wie hast du es erledigt?

  10. ottoplev

    mein eigenes WLAN kann ich im Monitor nicht sehen, sollte der von mir vergebene Name dort nicht erscheinen?

    1. David

      Doch sollte er. Sind alle Bedingungen erfüllt, wie das dauerhafte leuchten von D3 oder die Passwort länge?

      1. ottoplev

        D3 leuchtet dauerhaft. Im seriellen Monitor sehe ich es nicht, aber in den verfügbaren Netzwerkverbindungen am PC selber.

  11. Paul

    Leider ging meine vermutung nicht auf das die funktion wie ein „Wlanverstärker“ funktionieren könnte.
    Hoffentlich ändert sich dies durch die anderen Tage.
    Leider kann man nicht auf das „normale“ Internet zugreifen und browsen.

    1. Paul

      tut mir leid für das große bild
      hab das vergessen zu ändern

  12. D.T.

    Ich habe ebenen mein NanoESP anschließen wollen und die LED D3 hört einfach nicht auf zu blinken… kann mir da jemand weiter helfen? gibt es irgend eine reset Möglichkeit ?

    1. Paul

      Hatte das „problem“ auch einmal habe einfach ein anderes Basic programm aufs NanoESP hochgeladen dann hat es aufgehört. Hoffentlich funktioniert dies auch bei dir.

      1. D.T.

        Hab es gerade vergeblich versucht. bekomme ständig eine Fehlermeldung, dass ich nichts hochladen kann:

        Arduino: 1.6.13 (Mac OS X), Board: „Arduino Nano, ATmega328“

        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00

        Der Sketch verwendet 928 Bytes (3%) des Programmspeicherplatzes. Das Maximum sind 30.720 Bytes.
        Globale Variablen verwenden 9 Bytes (0%) des dynamischen Speichers, 2.039 Bytes für lokale Variablen verbleiben. Das Maximum sind 2.048 Bytes.
        Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
        avrdude: stk500_recv(): programmer is not responding
        avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
        Problem beim Hochladen auf das Board. Hilfestellung dazu unter http://www.arduino.cc/en/Guide/Troubleshooting#upload.

        Dieser Bericht wäre detaillierter, wenn die Option
        „Ausführliche Ausgabe während der Kompilierung“
        in Datei -> Voreinstellungen aktiviert wäre.

        1. D.T.

          Hab es nochmal an meinem Win PC ausprobiert. Lag am USB Port

        2. Michael Schuck

          Hatte das gleiche Problem mit MacOS Sierra und Arduino 1.6.6 und 1.7.11 nur durch Zufall habe ich noch eine alter Version ausprobiert 1.6.5-r5 und siehe da, es kommt keine Fehlermeldung mehr und alle Sketche lassen sich auf alle Arduino oder Clones hochladen. Muss doch irgendwo noch ein kleiner Käfer versteckt sein.

  13. Alan_the_H4cK3R

    Was bringt mir das? Ich kann weder auf die Easteregg Seite(ok, das wurde wahrscheinlich schon uberschrieben), noch auf andere Seiten im „richtigen“ Internet. Sinn?

    1. Funky185540

      Hallo,

      Wie du schon richtig erkannt hast wurde die Seite mit dem Easteregg bereits durch das hochladen des neuen Codes überschrieben.
      Durch das einrichten dieses „Access Points“ hast du dir ein Intranet (!) geschaffen. Das bedeutet: Wenn du dich mich anderen Geräten mit dem Access Point verbindest, so können diese Geräte nun über das Intranet miteinander kommunizieren, eben über das NanoESP Board.
      Das NanoESP Board hat jedoch noch keine Verbindung zu einem Router bzw. einem „richtigen“ WLAN Netzwerk. Somit kannst du mit dem bisherigen Code noch nicht ohne weiteres nach „außen kommunizieren“.
      Wenn du eine „echt“ Internetverbindung herstellen möchtest, kannst du ja schon ein mal einen Blick in die Library werfen oder die sog. „AT-Commands“ zu dem ESP8266 Wifi-Modul auf dem NanoESP nachschlagen, ich denke jedoch, dass dies in den nächsten Tagen noch auf uns zukommen wird.

      Hoffe, dass hilft dir weiter.

  14. JanR

    „Das Passwort muss aber mindestens 8 Zeichen haben.“ war ein wichtiger Satz beim zweiten Durchlesen. Wenn das Passwort zu kurz ist, passiert nichts, keine Reaktion, keine Fehlermeldung, Stille.
    Na ja, das gab mir zumindest die Gelegenheit, mich mit Serial.println() anzufreunden.

  15. SilentGuy

    Habe noch nie mit so nem Plugboard gearbeitet… Sehe ich das an Hand des Verkabelungsvorschlages richtig, dass die Pins in der oberste und die unterste Zeile horizontal verbunden sind und die in anderen vertikal?

    1. Sören

      Ja, das sind sie :)

  16. prisma01

    hmmm, habe den Namen des WLAN AP geändert, Passwort vergeben.
    jetzt komm ich nicht mehr auf die 192.168.4.1, wenngleich mein Rechner ordnungsgemäß damit verbunden wurde, er hat 192.168.4.2, aber die Webseite ist nicht erreichbar…

    wasndalos?

    1. SilentGuy

      Bin mir relativ sicher die Seite war nur ein easteregg auf Tag 1 die wir mittlerweile durch unsere andere Programme überschrieben haben

      1. JanR

        Ich kann …4.1 und …4.2 anpingen, aber die Webseite ist weg. SilentGuy hat wahrscheinlich Recht und die Seite ist jetzt überschrieben. Bei den wenigen KB, die wir haben. Ist das kein Wunder. Bin gespannt, ob wir noch mehr über den Speicher lernen werden.

  17. Michael Colin

    Dreiter

  18. Daniel the Newby

    Zweiter…

  19. Alan_the_H4ck3R

    Erster…

Schreiben Sie einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.