Hardware Informationen

Foren Das NanoESP & Pretzel Board Forum Hardware Hardware Informationen

Ansicht von 12 Beiträgen - 1 bis 12 (von insgesamt 12)
  • Autor
    Beiträge
  • #793
    fk
    Verwalter

    Hi,

    da ich es gerade zeitlich nicht schaffe noch ein paar Informationen in einem Beitrag aufzuarbeiten hier mal ein Sammelsurium an Informationshäppchen.

    PDFs:
    Schaltplan Arduino Nano (Original Rev 3)
    Pinout Arduino Nano (von pighixxx.com)
    Datenblatt CH340G (USB-to-Serial Chip)
    Datenblatt ESP8266 (WLAN-Modul)
    AT-Firmware Informationen

    #895
    McElch
    Mitglied

    Eine Frage drängt sich dem Anfänger auf:

    Überall, wo es ums NanoESP Wifi-Board geht (hier, Conrad, Franzis) steht einerseits, dass das Board Nano-kompatibel ist. Es steht aber auch überall, dass es 6 analoge Eingänge hat.

    In allen Dokus über den Nano steht, dass er 8 analoge Eingänge hat.

    Das Nano ESP Wifi Board hat auch Pins A0 bis A7, wenn mich meine Augen nicht trügen.

    Im hier oben verlinkten Pinout Arduino Nano steht bei Pin A6 und A7 mit einem roten Ausrufezeichen "Analog exclusively Pins".

    Was hat es denn nun mit diesen beiden mysteriösen Pins auf sich? Kann man die als analoge Eingänge nehmen oder nicht?

    Auch an dieser Stelle nochmal: Der Kalender ist klasse, macht großen Spaß, hat einen guten Lerneffekt und wird sicher nicht nur bei mir der Einstieg in das spannende Thema Arduino sein! :)

    Vielen Dank!

    #896
    fk
    Verwalter

    Hi,
    ja du hast recht es gibt 8 analoge Eingänge (2 mehr als beim Uno) die letzen beiden analogen Eingänge (A6 & A7) können allerdings nicht als digitale Ausgänge benutzt werden (im Gegensatz zu den anderen analogen Pins)

    #897
    McElch
    Mitglied

    Na das ist doch gut zu wissen, danke für die schnelle Info!

    #902
    Klaus
    Teilnehmer

    Die angegebenen Schaltungen passen aber nur sehr oberflächlich zum Nanoesp. Da sind schon vom Arduino Nano einige Unterschiede. Gibt es denn keine Schaltung von genau dem Board? Irgendjemand muss davon doch was haben.

    #949
    Joerg
    Mitglied

    Hallo zusammen,

    es wäre interessant zu wissen, welche WLAN-Standards und Verschlüsselungsmodi mit dem NanoESP zuverlässig funktionieren. Laut obigem Datenblatt unterstützt das ESP-Modul ja 802.11 b/g/n und sowohl WPA-PSK als auch WPA2-PSK.

    Im Forum berichteten aber andere Kalenderfreunde von Problemen der Anmeldung am Access-Point unter 802.11n. Bei ist es eher der Verschlüsselungsmodus: die Verbindung zum Access-Point klappt nur, wenn ich diesen auf WPA-PSK [TKIP] einstelle. In der Standard-Einstellung (WPA2-PSK [AES], 802.11n) bekomme ich immer die Meldung +CWJAP:1 FAIL oder auch +CWJAP:3 FAIL.

    An dem Router/Access-Point selbst scheint es nicht zu liegen, denn das Problem ließ sich an einem anderen Access-Point/Router eines anderen Herstellers reproduzieren.

    Merkwürdig ist auch, dass der gemischte Modus (WPA-PSK [TKIP] + WPA2-PSK [AES]) auch nicht funktioniert, obwohl Clients sich ja hier mit WPA-PSK [TKIP] anmelden können.

    Daher meine Frage: gibt es noch Möglichkeiten, diese Verbindungsprobleme zum Access-Point etwas detaillierter zu analysieren. Das "+CWJAP:1 FAIL" ist ja nicht gerade übermäßig verbos. Der Rückgabewert CWJAP:1 sagt ja "connecting timeout", die Frage wäre also, ob man diesen Timeout des ESP8266 etwas hochsetzten kann (und das ist wohl nicht der einstellbare Timeout der seriellen Schnittstelle).

    Haben vielleicht andere User ähnliche Probleme gehabt und eine Lösung gefunden?

    Wäre es vielleicht sinnvoll, ein Firmware-Update auf dem ESP-Modul zu versuchen (die installierte Version ist 0.22 und die aktuelle scheint bei 0.50 zu liegen)?

    Vielen Dank, Jörg

    #950
    Klaus
    Teilnehmer

    Ich hab es noch nicht ausprobiert. Muss erstmal sehen, mit welchem Router ich das mal probieren kann. Ich habe noch einzelne Module mit denen ich das gefahrlos testen könnte. Weiß nur nicht, wo ich die Firmware habe. Ich war mir sicher, ich habe mal eine runter geladen. Ich habe aber auch nur 4K-Mudule. Da passt nicht alles rein. Hast Du mal nen Link zu der neuen Firmware?

    #951
    Joerg
    Mitglied

    Die AT-Firmware gibt es wohl auf der Espressif-Seite . Ich weiß aber nicht, ob diese gefahrlos auf dem NanoESP installiert werden kann.

    #952
    Klaus
    Teilnehmer

    Danke für den Link. Die Seite hatte ich noch nie gesehen. Muss ich mir gleich mal speichern.
    Den Nanoesp werde ich erstmal gar nicht anrühren. Wie gesagt, ich hab noch kleine Module. Auf denen werde ich das erstmal testen.

    #956
    Klaus
    Teilnehmer

    Die neue Version ist scheinbar leider erst ab 8K. Da ich 4K-Module habe, kann ich sie nicht rein laden.

    #957
    Klaus
    Teilnehmer

    So, mal beide Module probiert. Also sowohl mit der Version 0.22 vom NanoESP, als auch mit Version 0.51 mit dem kleinen Modul können sich per WPA und WPA2 AES & TKIP verbinden. WEP habe ich jetzt nicht probiert, da das eh keiner mehr haben sollte.

    Was mir aufgefallen war, bei der neuen Version (0.51) passierte es, wenn ich die Verschlüsselung geändert hatte, dass das Modul nicht mehr ansprechbar war. Es bootete, wollte sich zum WLAN verbinden, was ja nicht klappte, und bottete wieder. Nur ein erneutes Aufspielen der Firmware half noch. Beim Nanoesp ist mir das nicht passiert.
    Also, lieber das Modul mit AT+CWMODE=2 vorher wieder in einen ansprechbaren Modus versetzen, oder WLAN-Daten löschen.

    #961
    Joerg
    Mitglied

    Danke, interessant. Ich habe es gerade an meinem Access-Point nochmal systematisch durchprobiert: bei mir nach wie vor keine Verbindung mit WPA2/AES. Nach Umstellen auf WPA/TKIP geht es wieder. Seltsam. Ich finde auch in der Doku zum AT Instruction Set keine Parameter, die ggf. noch im Flash gesetzt sind und die Verbindung über WPA2/AES verhindern könnten. Da muss ich wohl noch etwas weiter suchen…

Ansicht von 12 Beiträgen - 1 bis 12 (von insgesamt 12)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.