Tag 1 – Hinweis für Arduino Neulinge

Der erste Tag des Adventskalenders ist bereits rum und ich war überrascht und erfreut über all die Kommentare. Sehr gefreut hat mich vor allem die Bereitschaft der Community sich gegengeseitigt mit diesem zugegebenermaßen nicht völlig einfachen Thema zu helfen.

Aus den Kommentaren konnte ich außerdem herauslesen, dass der Ein oder Andere noch nie mit Arduino oder Mikrocontrollern im Allgemeinen zu tun hatte. Deswegen habe ich unter dem unten stehen Link einen längeren Artikel veröffentlicht, der ein Auszug aus einem meiner ersten Schnelleinstieg Hefte darstellt. Ich hoffe, dass ich damit einigen Leuten den Einstieg in den Adventskalender erleichtern kann.

Viel Spaß beim ausprobieren :)

Link zum Artikel: Schnellstart mit dem NanoESP für Arduino Neulinge

13 Kommentare

  1. DS2072

    Hallo,

    wenn ich die Platine auf das Breadboard stecke, wird keine Verbindung zum W-Lan aufgebaut. Ich habe das Breadboard aus dem Kalender benutzt, so wie noch eines der gleichen Marke und ein größeres. Definitv, ich schaffe es nicht eine Verbindung zu bekommen. Als Test verwendete ich das Programm Ping aus der Beispielbibliothek.

    Das Interessante, wenn ich die Platine vom Steckbrett abmache und dann, läuft alles ohne Probleme. Hat jemand eine Idee, wo das Problem liegt?

  2. Zacke

    Soweit funzt alles, aber im seriellen Monitor werden keine Zeichen dargestellt, somit können auch keine Befehle eingegeben werden…
    Habe aus der Beispieldatei den „Spannungsmesser“ hochgeladen, da fließen nur kryptische Zeichen durch den Monitor, was läuft da schief?

    1. Klaus

      Versuch mal ein anderes Terminalprogramm (z.B. https://sites.google.com/site/terminalbpp/)
      Ich hatte diese Effekte auch zu Anfang. Mit dem einen terminalprogramm geht es, mit dem anderen nicht. Als ich mit der Baudrate rum gespielt habe (in dem obigen Tool kannst Du custom setzen), wurde es besser. Anscheinend stimmt der Takt des Mikrocontrollers nicht so richtig.

      Wichtig bei dem obigen Tool ist, links leben dem „-> send“-Button das Häkchen bei „+CR“ setzen und aufpassen. Die Eingabezeile wird nach dem Drücken von Enter NICHT gelöscht

      1. Zacke

        Hi Klaus,
        vielen Dank für die superschnelle Hilfe, anderes Terminal, alle settings erledigt und schon läuft die „Kiste“ ;-)

  3. Klaus

    Das Modul wird recht warm. Finde ich für Halbleiter nicht gesund. Ich habe mal das Nanoesp mit dem kleinen ESP8266 verglichen:
    ESP8266: http://img5.fotos-hochladen.net/uploads/esp8266dfgt2scuei.jpg
    NanoESP: http://img5.fotos-hochladen.net/uploads/nanoespeluosgkrcj.jpg
    Das kleine Board wird auch schon recht warm.

  4. Bernhard

    Danke für die ergänzenden Hinweise.

    Eigentlich bin ich kein reiner Anfänger bei der Programmierung von Mikrokontrollern und so dachte ich per Kalendertürchen in kleinen Schritten in das Thema IOT einsteigen zu können.
    Alle im Haus vorhandenen USB-Kabel zu durchsuchen… Ich habe kein Smartphone – zum Glück lag irgendwo noch ein Ladegerät von den Kindern. o.k. fällt unter eigene Naivität.
    Eine Bedienungsanleitung die empfiehlt dieselbe nicht zu benutzen – das hatte ich noch nicht.
    Der fehlende Hinweis auf die Treiberinstallation – das hätte nicht sein müssen

    Auf ein Neues… Vielleicht klappt Tag 1 ja am Tag 2

  5. ohneName

    Was gebe ich für „MyPassword“ ein, wenn ich kein Passwort habe? (ungesichertes WLAN)

    1. ohneName

      ich bin maximal frustriert und meine Freude auf das nächste Türchen ist dahin. Die Idee für den Kalender ist sicher gut, aber nochmal würde ich nicht mehr soviel Geld ausgeben.

      1. ohneName

        mit dem Hotspot vom Handy bekomme ich eine Verbindung, aber bei PING zu Google kommt ERROR. So viele Stunden, um wieder vor dem nächsten Problem zu stehen… Gute Nacht.

        1. fk (Beitrag Autor)

          Hi, du könntest eine andere Webseite ausprobieren oder die Timeout Grenze hochsetzen.

  6. HuPeO

    Danke für den Hinweis mit dem Link! Ich bin absoluter Neuling was Mikrocontroller angeht und hatte vorher noch nie etwas von Arduino gehört (mein Sohne hatte mir den Kalender geschenkt). Ich habe mich anhand der lebhaften Kommentare am Tag 1 zwar zu einer erfolgreichen Inbetriebnahme durchgehangelt, aber mit dem Wissen aus dem oben verlinkten Artikel wäre es erheblich schneller gegangen. Nun weiß ich jedenfalls ungefähr was auf der Platine passiert, dass man ein USB Kabel braucht, einen Treiber installieren muss (für Mac OS X) usw… ;-)

  7. Nino1401

    Bei mir wird die Platine nicht erkannt obwohl ich den Treiber installiert habe…

    1. fk (Beitrag Autor)

      Erscheint die Platine nicht im Gerätemanager? In vielen Kommentaren habe ich gelesen, dass es an dem verwendeten Kabel liegen kann. Versuche mal ein anderes MicroUSB-Kabel.

Schreiben Sie einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.