(Deutsch) Firmware Neuigkeiten und Bug Report

Sorry, this entry is only available in German.

26 Comments

  1. J.J.

    Hallo Fabian (fk),

    tut mir leid, immer noch ein Problem mit der neuen Firmware (1v3_161218, Vers.2) melden zu müssen, aber beim Versuch von Tag 14 ("Smarte Lichter"), lassen sich den vier Touch-Buttons keine Reaktion entlocken. Den "Touch Threshold" habe ich zwischen 5 und 65 variiert, ohne Resultat. Die zwei On/off-Taster funktionieren, d.h. MQTT-Nachrichten werden generell vom Board versendet.

    Nachdem ich jetzt zum 2. Mal auf die 1v2_261018 Firmware zurück gegangen bin, funktioniert hingegen wieder alles.

    Viele Grüße, J.J.

    Reply
    1. fk (Post author)

      Okay, vielen Danke für die Info. Ich schaue mir das heute Nachmittag Mal an.

      Reply
  2. paulaner

    immernoch Vorversion der FW.

    Reply
    1. fk (Post author)

      Was meinst du genau? Der Name der Bin-Version hat sich nicht geändert aber es ist ein neues Programm. Über die Config-Seite sollte das Update ebenfalls geladen werden können.

      Reply
      1. paulaner

        Hallo,

        da man ja nicht die Nachrichten/Antworten editieren kann, habe ich es noch zu der vorherigen Frage/Bild 'nachgeschickt', nicht das diese Frage noch kommt.

        Jetzt, habe ich auch die neue FW eigespielt, bis jetzt läuft es super.
        Mit dem eigenen Broker auf dem RPi und Win muß ich noch testen.
        Frage: Muss man beim Start des Brokers Benutzer/Passwort mit übergeben und wie sieht das kongret aus,
        z.B. beim RPi.

        Danke

        Reply
        1. Abu Kali

          Hi,

          schau z.B. bei "Step 5": https://www.digitalocean.com/community/tutorials/how-to-install-and-secure-the-mosquitto-mqtt-messaging-broker-on-ubuntu-16-04#step-5-%E2%80%94-configuring-mqtt-passwords

          Ob ein User/PW erforderlich sind, kann in der conf-Datei (/etc/mosquitto/conf.d/default.conf) eingestellt werden:
          allow_anonymous=false

          Beim Start des Brokers muss kein User/PW übergeben werden, aber bei publish/subscribe (falls so eingestellt) – also auch in den NodeRed-Flows.

          Reply
          1. paulaner

            Danke

  3. paulaner

    Hallo fk.,

    warum erscheinen die Programme?
    Vorher war da nur 'eins' zusehen. Webserver.
    Unter IoT Adventcalendar 2018, da gab es die vielen.

    Reply
    1. fk (Post author)

      Hallo, das sind generelle Beispielprogramme für das Board. Waren diese Programme bei der letzten Version noch nicht dabei?

      Reply
      1. paulaner

        Hallo,

        bei mir jedenfalls war nur das erste zusehen.
        Frage: zu den vorhandene 6 Programmen, wenn ich die in den NodeESP lade, werde ich sicher auch den entspechenden Flow brauchen?
        Oder zumindestens die IO’s etc..

        Reply
      2. J.J.

        Doch, sind definitiv in der Version 1v2_261018 auch schon da (habe diese gerade noch am Laufen, bevor ich gleich updaten werden).
        Die Anzeige der aktuell laufenden Firmware-Version auf der Web-Oberfläche wäre m.E. übrigens sehr sinnvoll.

        Viele Grüße, J.J.

        Reply
  4. fk (Post author)

    Hallo,
    ich habe jetzt den Fehler in der MQTT-Funktion gefunden. Ich hoffe jetzt funktioniert alles.

    Reply
    1. Abu Kali

      Funktioniert bestens! Sowohl broker.fkainka.de (ohne Credentials) als der eigene Mosquitto mit Credentials.
      Viell. ein Hinweis darauf geben, dass auch im NodeRED die Credentials angegeben werden müssen, falls solche verwendet werden?

      Reply
  5. paulaner

    Hallo,

    alte FW geht wieder alles, Button, Broker, ok.

    Reply
  6. J.J.

    Moin,

    ich habe das Update ebenfalls eingespielt, nachdem ich den Versuch von Tag 12 (MQTT-Buttons) gemacht hatte (hinke zeitlich etwas hinterher). Seitdem habe ich folgende Fehler (ich verwende einen lokalen Mosquitto-Server):

    * Tag 12: Beim Drücken der Buttons werden keine MQTT-Nachrichten mehr versendet — weder an NodeESP/+/button/state/get/out, noch an NodeESP/+/out.

    * Tag 13: Der NodeESP versendet an NodeESP/+/out, aber nicht an NodeESP/+/touch/state/get/out.

    * Tag 14: Wie bei Tag 12 kommen keinerlei MQTT-Nachrichten mehr an.

    Insgesamt also ein ziemlicher Cooler… :-(
    Ich würde gerne wieder die vorherige Firmware-Version installieren, um zu sehen, ob es danach wieder funktioniert. Wo kann man die herunterladen?

    Danke & Gruß, J.J.

    Reply
    1. paulaner

      genauso bei mir.
      Versuche mal die vorherige FW zuflashen, hoffe nicht das es noch zusätzlich an Broker liegt, nacch den 3 'Verschlimmbesserungen'.

      Hast du die etwa nicht (FW)?

      Reply
      1. J.J.

        Nope, habe in beiden Fällen einfach ein OTA Update gemacht und sie mir vorher nicht separat heruntergeladen. Grundsätzlich bin ich ein sehr optimistischer Mensch… ;-)

        Reply
        1. paulaner

          ich habe noch die vorherige .bin und die neue .bin, sind aber beide 4MB groß und gleich bezeichnet, jetzt kann ich sie ja noch umbennen, aber ich weis nicht was drinnen steht.

          Entweder lädt fk. diese noch hoch oder bringt die Bugs noch aus der neuen.

          Reply
          1. fk (Post author)

            Ich schaue mir gerade die Firmware an und obwohl sich das Board richtig zu Verbinden scheint (eine Meldung erscheint im Broker) und auch bei Tastendruck über den Seriellen Monitor verlauten lässt, dass er eine Meldung gepublished hätte, erscheint keine Meldung im Broker. Ich werde jetzt die beiden Firmware als Bin-Datei hier auf diese Seite stellen und noch mal schauen, woran es liegt. Eventuell gibt es auch ein Problem beim Broker.

          2. J.J.

            @fk: Vielen Dank. Nach Flashen der alten Firmware 1v2_261018 treten die drei von mir beschriebenen Fehler nicht mehr auf und die Experimente funktionieren wieder. :)

    2. paulaner

      wichtig, Sleep Brücke sonst geht Der Tuch nicht!!!

      Reply
  7. paulaner

    Hallo, jetzt habe ich das Update eingespielt.
    Jetzt bekomme ich im NodeESP nach dem Eintraden eines Benutzers/Passwortes keine 'Test Connection'.
    Lass ich beides weg klappt die Test Connetion.

    Reply
    1. paulaner

      das selbe Problem im Flow vom Tag12.
      Connction entweder rot oder gelb, mit oder ohne Benutzer/Passwort.

      Reply
      1. paulaner

        Hallo, noch das
        16 Dec 17:21:47 – [info] [mqtt-broker:fkainka.de] Connection failed to broker: mqtt://broker.fkainka.de:1883

        Reply
        1. fk (Post author)

          Hallo, auf dem Broker Broker.fkainka.de wird kein Nutzername und Passwort benötigt. Die Einstellungen ist nur für selbst eingerichtete Broker.

          Reply
          1. paulaner

            Danke

Leave a Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.