(Deutsch) NodeESP Firmware Reinstallieren

Sorry, this entry is only available in German.

29 Comments

  1. jfkal

    Adventskalender fuer Kinder ab 14?
    Echt ein Lacher, wenn man sich die Probleme der großen Kinder verfolgt.
    Eines have ich hier schnell gelernt: IoT kommt mir nicht ins Haus ;-) .

    Reply
  2. jfkal

    Ziemlicher Schrott. Power up . LED blinkt grün und nix funktioniert. Waste off money.

    Reply
    1. fk (Post author)

      Wenn du den Fehler genauer beschreiben würdest, könnten wir versuchen dir zu helfen.

      Reply
      1. jfkal

        Mehr ist da nicht. LED blinkt nur grün.
        WPS geht nicht . Board Hotspot Zugang geht auch nicht.

        Reply
        1. fk (Post author)

          Hast du Zugang zu einem Seriellen Monitor, z.B. über die Arduino IDE?

          Reply
  3. Hans-Joachim

    Mit dieser Beschreibung verlief das Flashupdate über einen Windows10-PC völlig problemlos. Bei der WLAN-Anbindung per WPS gab es nach dem Flashupdate ebenso keine Probleme. Der Router erkannte das Board wieder.

    Reply
  4. Fabio

    Hallo, nach dem neuen laden der Firmware habe ich die WLAN Daten neu konfiguriert. Funktioniert soweit alles. Nun wollte ich das heutige Programm unter den Application Settings auswählen. Diese sind nun nicht mehr auf dem Board gespeichert. Wie kann ich die wieder aufs Board laden?
    Danke für die Hilfe.

    Reply
  5. Martin

    Hallo

    Ich habe einen Mac mit MacOS High Sierra. Dieses Flash Tool ist aber nur für Windows. Wie kann ich die Firmware flashen?

    Besten Dank und Gruss
    Martin

    Reply
    1. Jörg Gronmayer

      Das würde mich ebenfalls interessieren! Habe auch nur Mac und muss das Board neu flashen. Bitte um Hilfe!

      Reply
      1. Andreas

        Ich würde euch beiden mal einen Blick auf https://github.com/espressif/esptool empfehlen – ist in Python programmiert und ich hab es bei mit unter Linux probiert. Da MacOS ja BSD-artig ist, vermute ich, dass es da auch gehen sollte.

        Reply
  6. Helge

    Hallo,
    bei mir tritt folgender flash-Fehler auf:
    ESP8266 Chip stub error esp_stub_and_set_boud ?
    Bin hilflos ..
    Danke!

    Reply
    1. fk (Post author)

      Hallo, hast du den esp8266 statt dem Esp32 Chip ausgewählt?

      Reply
  7. Gabriel

    Hallo Fabian,
    ist mein Board (bzw. die LED) defekt, wenn die RGB-LED nicht leuchtet?
    Ich kann das Board über micro USB an den PC anschließen und komme auch auf die Board Konfiguration.
    Die Wlan Daten konnte ich eingeben und auch schickt der NodeEPS Daten (Tag 3 Aufgabe).
    Ich muss aber täglich die Wlan Daten neu eintragen, was ein bisschen lästig ist.
    Flashen hat das Lämpchen auch nicht zum Leuchten gebracht.

    Reply
    1. fk (Post author)

      Hallo, wenn die LED prinzipiell nie leuchtet, auch wenn entsprechende Option eingestellt ist, ist das in der Tat kein gutes Zeichen und die LED defekt und sollte umgetauscht werden. Das Speichern der WLAN Daten sollte theoretisch aber dennoch funktionieren.

      Reply
  8. FeFe_05

    Hallo, bei mir funktioniert das leider alles nicht.
    (Ich wollte die Firmware updaten, da das board nicht wie beschrieben gelb leuchtet sondern erst kurz grün leuchtet und danach rot blinkt. Es wird kein WLAN aufgebaut.)
    Im Tool wird immer ewig SYNC angezeigt, irgendwann dann FAIL.
    Folgender Fehler wird angezeigt:(siehe Bild)

    Reply
    1. fk (Post author)

      Hallo, hast du eventuell noch einen Seriellen Monitor offen? Du kannst auch Mal Versuchen, die WPS Taste gedrückt zu halten, während du die Reset Taste kurz drückst. Das Board sollte dann manuell in den Flashmodus gehen (was es normalerweise automatisch macht)

      Reply
      1. FeFe_05

        Das flashen hat geklappt, restarte ich das nodeESP aber, blinkt die LED wieder rot und es wird kein Wlan-Netzwerk aufgebaut.

        Reply
  9. Meichr

    Hallo,
    nach den IOT-Adventkalendern mit dem NanoESP wieder ein sehr interessanter Kalender für mich.

    Reinstallation der Firmware ohne Probleme, danke für die ausführliche Beschreibung.

    Beim Verbinden mit dem lokalen W-Lan über die Konfigurations-Seite habe ich allerdings eine Unschönheit, dass nach Eingabe eines fehlerhaften Passwortes ab dem zweiten Versuch die "WiFi Station Settings"-Liste nicht mehr permanent angezeigt wird. Die Liste wird zwar gescannt, jedoch verschwinden alle gefundenen SSIDs nach einer Sekunden wieder aus der Select-Box.

    Abhilfe dafür ist, dass man die Standard-Konfiguration wieder herstellt.

    Gruß,
    Meichr.

    Reply
  10. SilMai

    Moin, Moin
    Nach Aufspielen der FW und einem Neustarten des NodeESP kein neues WLAN. Wenn ich putty draufgehe, kommt nur die Meldung
    RUN
    Config file deleted
    No config file found. Loading default
    Config updated. Restarting

    und das als Endlosschleife.

    Reply
    1. fk (Post author)

      Hallo, kann es sein, dass etwas an Pin 13 des Board angeschlossen ist? Wenn Pin 13 beim Starten des Boards LOW ist, wird die Config-Datei resettet indem die Datei gelöscht wird und das Board resettet wird. Das scheint hier der Fall zu sein.

      Reply
      1. SilMai

        Danke für den Tip. Ein Steckboard war nicht i.O. Nach dem Austausch ging alles.

        Reply
  11. Erik

    Wird es auch den Source-Code für die Firmware geben? Nur damit wäre ein wirkliches Lernen und erweitern möglich. Besten Dank im voraus.

    Reply
    1. fk (Post author)

      Der Source Code wird, zumindest in den nächsten Tagen, noch nicht veröffentlicht. Es ist aber sehr wahrscheinlich dass er veröffentlicht wird.

      Reply
      1. SilMai

        über Arduino-IDE kann ich flashen.

        Reply
  12. abutux

    Graphisch gibt’s für Linux etc. nicht. Es klappt aber mit esptool.py (Download: https://github.com/espressif/esp-idf.git). Ins Verzeichnis wechseln: esp-idf/components/esptool_py/esptool/ und

    ./esptool.py -p write_flash -z 0x0 ~/Downloads/ESP32_FW.bin

    = /dev/ttyUSB0 oder /dev/ttyUSB1 usw.

    Dann mit NodeESP verbinden usw.

    NB: am besten vorher ./esptool.py -p erase_flash ausführen

    Reply
    1. abutux

      S. http://inre.dundeemt.com/2017-09-26/mpy-on-esp32-tools-esptool-py/

      Es wurde etwas unterschlagen (das, was in spitzen Klammern stand): '-p [port]' [port] = /dev/ttyUSB0 od. /dev/ttyUSB1 o.ä.

      Reply
      1. Christian

        Bei mir hat folgendes funktioniert:

        sudo easy_install pip
        sudo pip install esptool
        ls /dev/tty.*
        # den richtigen Port auswählen und …
        esptool.py -p /dev/tty.usbserial-1430 write_flash -z 0x0 ~/Downloads/ESP32_FW.bin

        Reply
    2. Ant Kutschera

      hat geklappt nachdem ich mit dem arduino ide ein eigenes programmchen hochgeladen habe – danke für den tipp! :-)

      Reply
  13. morob

    gibt es für die firmware auch ein linuxtool?

    Reply

Leave a Comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.